DodgeCharger.com Forum
June 20, 2019, 05:40:33 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Please remember: this is the place to discuss Chargers - NOT the place to discuss politics. Political posts will be locked or deleted at the Moderator's discretion.
 
   Home   Help Calendar Login Register Chat  
Pages: [1]   Go Down
  Print  
Author Topic: Someone post a pic of their leaf springs for 68-70 Charger RT,how they mount???  (Read 1848 times)
Blakcharger440
Old Timer
*****
Offline Offline

Posts: 1,160


« on: August 28, 2005, 09:16:37 AM »

Could someone post a pic of their stock rear leaf spring hangers on a 68-70 Charger RT as installed on their car??

Are they supposed to come down exactly straight or do they angle a little toward the front or back???


Could someone also post a pic of how the front spring mount is bolted in also for the same car.
Logged
Charger Aficionado
Old Timer
*****
Offline Offline

Posts: 1,404


Charger Fanatic


WWW
« Reply #1 on: August 28, 2005, 12:37:56 PM »

  I temporarily mounted my Dana 60 on with the front bolt-in braces on the wrong sides...  I did this because the previous owner welded the Nut in place, and this way I could wrench the bolt (gave me room to get it).  I wonder if they are angled a certain direction if the rear leafs were at some sort of diagnal angle (looking directly up from bottom)Huh  If so I may wear out the bushing on the front of the new springs?  I should just put it back to how it was... It's not torqued down yet so I'm set.
Logged

TurquoiseRT
New Member
*
Offline Offline

Posts: 20


« Reply #2 on: August 28, 2005, 06:47:31 PM »

These are the best I have fromwhen I changed my springs last year.

THey angle towards the front a bit.

Hope this helps


* P8300007.JPG (72.71 KB, 640x480 - viewed 370 times.)

* P8300017.JPG (65.06 KB, 640x480 - viewed 354 times.)
Logged
TurquoiseRT
New Member
*
Offline Offline

Posts: 20


« Reply #3 on: August 28, 2005, 06:54:05 PM »

This is the front springer hanger.

BTW this is a 69 Charger R/T

Jeff


* P8300013.JPG (68.97 KB, 640x480 - viewed 344 times.)
Logged
Blakcharger440
Old Timer
*****
Offline Offline

Posts: 1,160


« Reply #4 on: August 28, 2005, 07:15:15 PM »

Thanks Turquoise RT!!!
I figured I had them mounted right! I was afraid that I messed up in mounting them somehow and would have to yank em down again. It is now ready for the Dana to get back from the shop so that I can install it.

Thanks again...oh and by the pic that you took it looks like you have a 3 inch exhaust system? What kind did you go with?
Logged
TurquoiseRT
New Member
*
Offline Offline

Posts: 20


« Reply #5 on: August 28, 2005, 07:55:15 PM »

Nope 2 1/2"

Cheap crap that the place the redid my engine say they put on. Notice the overspray??? they said they changed the pipes, considering it was painted years before,   I dont think they changed them.
Logged
Blakcharger440
Old Timer
*****
Offline Offline

Posts: 1,160


« Reply #6 on: August 29, 2005, 05:28:38 PM »

That sucks if they didnt change them. That is just bad business.  rotz
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 0.045 seconds with 16 queries.